Certificates were refreshed with invalid certificate chains - potentially resulting in dropped requests.

Incident Report for Palantir Foundry UK

Resolved

The situation is back to normal, and services are operating normally.
Posted Jun 26, 2025 - 17:05 BST

Monitoring

We are currently monitoring the issue after taking remediative actions.

Please be aware of any networking issues that appear, they could be related to this certificate issue which needs manual remediation. Broad remediation could not be undertaken as it would cause more downtime for domains that may not have been affected by this issue.
Posted Jun 26, 2025 - 06:56 BST